In EZReporter 4.0. if you experience a Background Processing Error with the description “The RPC server is unavailable”, this is almost always due to an issue with the default printer – typically a network printer that is not accessible, but there may be other causes.
Here are a few troubleshooting suggestions:
- Try printing to the default Windows printer from another application. If this also fails than you will need to determine the cause of the problem with the default printer, including the wrong default printer being used, or networking or other problems.
- If you recently changed the default printer being used on your computer, try switching back to the previous default printer and see if that resolves the problem.
- If the Windows Printing Preferences are set with “Let Windows manage my default printer” enabled, then the wrong printer may be currently specified as the default. See the discussion below for solutions to this problem.
Background information:
If you configure EZReporter to automatically print a report or save a PDF file at the end of each run, EZReporter uses whatever printer is currently designated as the default printer. If you have the “Let Windows manage my default printer” enabled in the “Printer preferences” under the “Printers & Scanners” settings, then the default printer may not be set to the desired printer. If this is the case, set this option to “Off”:

Next, find the desired printer in the list of printers and scanners and click it to display the settings for that printer. There should now be a “Set as default” button at the top of the printer settings. Click this to force Windows to use this printer as the default. Then, try reprocessing the sample in EZReporter.
